Skip Navigation

[Gelöst] Unable to upload using cred form when connected with the role "membre"

This support ticket is created vor 4 Jahre, 3 Monate. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 -
- 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 -

Supporter timezone: Europe/London (GMT+00:00)

This topic contains 3 Antworten, has 2 Stimmen.

Last updated by Jean-Philippe vor 4 Jahre, 3 Monate.

Assigned support staff: Nigel.

Author
Artikel
#1120146

We have a few cred form that edit different custom post. Since a few days our site user with the role Membre have been unable to upload file using those form. We always get the same error: "There was an error uploading your file."
If we use an Administrator account, we can upload file without problem.
I activated the debug log but i couldn't find anything regarding an error with the upload.

#1120670

Nigel
Supporter

Languages: Englisch (English ) Spanisch (Español )

Timezone: Europe/London (GMT+00:00)

Hi there

We just released a hotfix for Toolset Forms (2.1.1.2) to resolve problems that arose from a recent change to how JS assets are enqueued with forms, and I suspect the problem you are describing may fall under the same issue.

Could you please update and then test again, and if you still see the problem let me know and I'll investigate further.

#1120708

After updating the plugin to 2.1.1.2, an error started showing up on the js console: "Toolset Forms: Error parsing callback data for `check_post_id` ".
This error show up only once when the form page is loaded and only if the user have the role Membre.

#1120797

My issue is resolved now. Thank you!
I had an redirection on admin_init for the member role, since admin_init is called when wp-ajax is used the form was send to the wrong page.