Skip Navigation

[Gelöst] Search + Results on other page: price min/max & sq foot min/max don't work.

This support ticket is created vor 3 Jahre, 2 Monate. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 4 Antworten, has 2 Stimmen.

Last updated by Bob Dowdy vor 3 Jahre, 2 Monate.

Assigned support staff: Christian Cox.

Author
Artikel
#1214221

I am trying to:
Make a search bar that sits in the top header, with the search results appearing on a different page

Link to a page where the issue can be seen:
hidden link
(password: hgdemo)

I expected to see:
Search results with either the min/max price or Sq foot min/max entered show all listings with prices/sq footage in that range.

Instead, I got:
All products.

Other Notes:
- There is another view with search that works - but ONLY if you do not enter commas: hidden link
-- I understand that you cannot enter commas into a Numeral field. But in my testing if I use a String the ordering of the table doesn't come out right... any suggestions?

- I am using a custom shortcode (provided from a different ticket) that adds commas to price and square footage.

#1214231

Looking at some support documents, it looks as though using a dropdown for min/max fields may be preferable. I am going to investigate that I was await your reply. Thank you!

#1214256

Ok, so the dropdowns are definitely what I am going to go with.

However, they still don't quite work.

I've currently got it setup to search between $10,000 and $200,000, but when you do that search numbers above 200,000 still show (like $1,024,000).

#1214327

Hi, can you edit this View in wp-admin and toggle open all the Query Filters? Take a screenshot so I can see all the settings. If you cannot see the Query Filters panel, scroll to the top right and click "Screen Options" to enable it. Please attach this screenshot in your next reply.

#1214350

Thanks Christian,

That pointed me in the right direction, and I found my mistake.
All fixed, and the form/search results are now working!

Best,
Corey