Skip Navigation

[Gelöst] Problems with responsive slider and flex slider after upgrade

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 5 Antworten, has 2 Stimmen.

Last updated by marijkeM vor 7 Jahre, 11 Monate.

Assigned support staff: emerson.

Author
Artikel
#163129
bootstrap.jpg

After upgrading wordpress and types and views a page with a flex slider is empty. When I remove the slider view the content is back again.

And my syntax editor looks weird. I have got an extra scroll bar.
I use a child theme of the bootstrap theme. On my local computer I don't have this problem. I tried many things, like trying on another page, disabling plugins, upgrading again, but nothing helps.

Any idea what the problem can be?

#163358

Dear marijkeM,
Have you also tried updating in your local computer to see if this problem occurs? It could a glitch with the update. I'm sending you the development version of Toolset Bootstrap for testing. Also make sure you are using the latest Types and Views as available here: https://toolset.com/my-account/downloads/
Backup your site database and files, then proceed as follows:

1.) Replace the old Toolset Bootstrap with the updated version (the one sent to you via email).
2.) Make sure you are using the updated Types and Views (Types 1.5.1 and Views 1.4.1). Delete and replace old plugins in your plugin directory.
3.) After updating check if its now working OK.

Please let me know how it goes. Thanks.

Cheers,
Emerson

#163779

Thank you Emerson,

It is not OK after updating :(. I tried disabling all plugins. Nothing helps. But the weird syntax editor problem is gone, so we are making progress!

I deleted and reinstalled the sliders with the Module Manager, but that didn't work either. May be it is because the first time I didn't install the slider with the Module Manager? I had problems with the tmp directory. I later resolved that and installed the sliders with the Module Manager. Other views work nice on the site.

I discovered the new woocommerce view and I am happy with it. Well done! But I still miss some shortcodes I use and may be other people would like too. See hidden link. I have a shortcode for amount and addtocart, for average rating and for comments (=reviews)

I have the slider in my homepage: hidden link But it doesn't show, because that is my problem. We want to go live with this site end of the week.

Regards,

Marijke

#163856

Dear Marijke,

Great that the syntax editor issue has been resolved. It seems the only now is with the sliders to get working. I’ll send you a private email right now asking you for some private information that will help me debug this issue for you. Please check your email in a couple of minutes, and if you don’t get it, let me know so I can send it again. I will take a look at your slider settings and do some debug.

Thanks.

Cheers,
Emerson

#164446
syntax_editor_working2.jpg
syntax_editor_working1.jpg

Dear Marijke,
I checked your site and debug the problem. The issue that is causing the flex sliders and responsive responsive sliders to stop working is relating to an update in Types. I fixed this by changing the url="true" to output="raw" and it is working now:

Thes are the changes made to fix the problem:

Responsive slider - single slide Content Template:

[php]
<li>
<img src="[types field="slide-image" output="raw" width="770" height="510"][/types]" alt="[wpv-post-title]">
</li>
[/php]

Flex slider - main slider - single slide Content Template
[php]
<li>
<img src="[types field="slide-image" output="raw" width="770" height="510"][/types]" alt="[wpv-post-title]">
</li>
[/php]

Flex slider nav - thumbnails - single thumbnail Content Template
[php]
<li>
<img src="[types field="slide-image" output="raw" width="120" height="80"][/types]" alt="[wpv-post-title]">
</li>
[/php]

See your homepage with the Responsive slider: hidden link
And this test page you created (I fixed it) for the Flex Slider example: hidden link

Also I never see any issues with the syntax editor for Bootstrap theme in the site , its working fine (see some screenshots) 🙂 I also noticed you are using an older version of module manager. Please use the built in module manager by the Bootstrap theme when importing modules from our reference site.

You can do that by deactivating the module manager plugin. When this old module manager is deactivated, you can use the module manager embedded version to import. Or you can also update to latest version of module manager as available in our downloads: https://toolset.com/downloads/

Thanks.

Cheers,
Emerson

#164499

Yesssss, wow!

What a luxury, your problems are solved while you sleep.

Thank you very much, Emerson.

Oh and the editor thing...it is Firefox. In Chrome I don't see it either.