Skip Navigation

[Gelöst] Parametric filter goes blank after object cache is enabled in W3 Total Cache

This support ticket is created vor 7 Jahre, 6 Monate. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

This topic contains 4 Antworten, has 2 Stimmen.

Last updated by mellisaB vor 7 Jahre, 6 Monate.

Assigned support staff: Luo Yang.

Author
Artikel
#322707

I have a parametric form with 4 select menu inputs that change the search results. They work as expected until I enable the Object Cache in W3 Total Cache plugin. I loose all the options from the pull down menu.
If I disable the object cache all the menus are repopulated and act normal.

hidden link shows the parametric form with 4 select menus that have no options. If I add the query to the URL the menus will partially populate.
?wpv-status=0&wpv-vehicle-type=car&wpv-vehicle-make=audi

Is there a specific JS script that I need to exclude from caching?
Is object caching just not compatible with a parametric search?

#322726

Luo Yang
Supporter

Languages: Englisch (English ) Vereinfachtes Chinesisch (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Dear mellisaB,

Are we talking about the plugin download from:
https://wordpress.org/plugins/w3-total-cache/
I can not duplicate same problem in my localhost,
Please try this, edit the problem view, in section "Parametric Search Settings", enable option "Let me choose individual settings manually", enable option "Always show all values for inputs", and test again.

#323021

Yes that is the plugin I'm using.
After changing the options as you said, the list does populate but the count is showing zero for unavailable options instead of hiding them. I have the filters using format="%%NAME%% %%COUNT%%".
Can I still have it only show available options for each input?

#323132

Luo Yang
Supporter

Languages: Englisch (English ) Vereinfachtes Chinesisch (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Sorry, As I mentioned above, I can not duplicate same problem in my localhost with W3 Total Cache plugin + Views.

If you get this: the count is showing zero
That means there isn't any posts in this custom field/taxonomy,

I suggest you check this:
For example, you are using Views to select posts of post type "my-cpt", please make sure you have registered those custom field/taxonomy into custom post type "my-cpt", and there is "my-cpt" posts which setup with those custom field/taxonomy value.

If not, I don't think it is possible to get the counts within Views.

#323391

Yes I understand about the zero. These taxonomies are registered to a CPT.
I really like having the count and being able to hide the options in the list as the user makes changes to the parametric search.
I have been fighting with the W3 plugin for a while, the object cache setting speeds up my site but breaks too many of Toolsets features. W3 debug kept telling me it could not cache pages because they contained a query. W3 never gave me the performance I thought it should. So I started looking for an alternative to W3 Total Cache and I found Redis. I installed it on my dedicated server as well as a wordpress plugin for Redis from GitHub.
WOW this is the fastest cache I have ever used!
It solved many of the problems I had with W3. My parametric search page took 51 seconds to display over 10,000 posts with 4 taxonomy search inputs. This new cache serves it up in .0014 seconds.
You guys should take a look at Redis.
Thanks for your help