Skip Navigation

[Gelöst] Limit relationship in form

Dieser Thread wurde gelöst. Hier ist eine Beschreibung des Problems und der Lösung.

Problem:

The issue here is that the user wanted to only display the parent posts that were created by the current user when they are adding a new child post.

Solution:

On the Edit Form page on the backend you will see your relationship field. What you need to do is to click the relationship field to expand it.

From there you will be presented with the option to "Get only options from current author".

This support ticket is created vor 2 Jahre, 6 Monate. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 -
- 13:00 – 18:00 13:00 – 18:00 13:00 – 18:00 14:00 – 18:00 13:00 – 18:00 -

Supporter timezone: America/Jamaica (GMT-05:00)

This topic contains 2 Antworten, has 2 Stimmen.

Last updated by romanF vor 2 Jahre, 6 Monate.

Assigned support staff: Shane.

Author
Artikel
#1702733
zugehörigkeit.jpg

Follow up to this ticket:
https://toolset.com/forums/topic/manage-relationship-access/
Summary: "I would like to show only the options of the current user when selection a relationship in a form"

I changed the system now to the frontend. But it still shows all the "akteur" and not just the ones from the current user. Sadly I could not figure out where the settings are that you showed on the screenshot. I do use a user content form and the last option of this is to select the parent (akteur) to this child (angebot). (See screenshot, it should only show one option there)

#1702877

Shane
Supporter

Languages: Englisch (English )

Timezone: America/Jamaica (GMT-05:00)

Screenshot 2020-07-10 at 10.53.39 AM.png

Hi Roman,

On the Edit Form page on the backend you will see your relationship field. What you need to do is to click the relationship field to expand it.

From there you will be presented with the option to "Get only options from current author". See my screenshot

In my case the Relationship field is called Post Cars but your relationship field should be reflected under the correct relationship name.

Please let me know if you were able to find the option.

Thanks,
Shane

#1703439

My issue is resolved now. Thank you!