Skip Navigation

[Gelöst] Layouts Admin page blank bug

This support ticket is created vor 5 Jahre, 7 Monate. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- - 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00
- - - - - - -

Supporter timezone: Asia/Ho_Chi_Minh (GMT+07:00)

This topic contains 6 Antworten, has 2 Stimmen.

Last updated by Beda vor 5 Jahre, 6 Monate.

Assisted by: Beda.

Author
Artikel
#953942
Screen Shot 2018-07-23 at 8.27.59 PM.png

I am trying to: View existing layouts

Link to a page where the issue can be seen: Layouts admin page

I expected to see: table of my layouts

Instead, I got: blank page

It seems I'm not the only one to come across this problem but I don't see any solutions.

https://toolset.com/forums/topic/list-of-layouts-not-displaying-in-admin-page-after-upgrading-to-version-2-4/
https://toolset.com/forums/topic/layouts-admin-page-blank/

Error log produces:

[24-Jul-2018 00:23:11 UTC] PHP Notice:  Undefined offset: 7925 in /nas/content/live/charmcat/wp-content/plugins/layouts/classes-auto/listing/stores/wpdd.listing-page-abstract.class.php on line 194
[24-Jul-2018 00:23:11 UTC] PHP Notice:  Trying to get property of non-object in /nas/content/live/charmcat/wp-content/plugins/layouts/classes-auto/listing/stores/wpdd.listing-page-abstract.class.php on line 194
#954290

Thanks for the report.

I see this is not happening:
https://toolset.com/forums/topic/list-of-layouts-not-displaying-in-admin-page-after-upgrading-to-version-2-4/

And this here throws an "Call to undefined method WPDD_layout_tabs_cell_factory::build() in /home/h2mcouk/public_html/wp-content/plugins/layouts/classes-auto/cells/wpddl-layout-cell-types.php on line 116" on one site, and with a totally different error on another site:
https://toolset.com/forums/topic/layouts-admin-page-blank/#post-616572

I don't understand however that https://toolset.com/forums/topic/layouts-admin-page-blank/ is still closed, as I explicitly discussed this.

However, lets not loose time, I took that ticket, and reopened it.
Lets handle this so to solve it

Could you add a copy of your site in the next reply?
https://toolset.com/faq/provide-supporters-copy-site/

Thanks.

#955383

I see you use several plugins and a custom theme, and I cannot debug this online

I need a copy of this site, locally so to provide it to someone that can fix the issue.

I would need at least a copy of the database.

I allowed myself to install a Plugin, export both databases you have and deployed them locally on a Toolset Fresh Install

The Toolset Layouts admin page shows and endless row of errors.

I used the database "snapshot", I assume that is a copy of the wp database, right?
I will now escalate this to the second tier.

#956683

Yes, the snapshot database is the staging copy of the database.

If needed, I can provide a manual zip of the complete site (files and database), I just can't create a duplicator package.

#957091

No, it's fine, in this case I provided the right one.

The issue is fixed already and in testing phase.

I will update you as soon it's released or else available to fix for you.

#1080200

This will be released next week.

I will be away, please look out after the update (presupposed mid week, if nothing goes wrong).

#1084499

This is released and fixed in Toolset Layouts 2.4.1

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.