Skip Navigation

[Gelöst] I need auto-insert paragraphs, but only on the wysiwyg fields

Dieser Thread wurde gelöst. Hier ist eine Beschreibung des Problems und der Lösung.

Problem:
I need auto-insert paragraphs, but only on the WYSIWYG fields. The trouble is that my content template contains all sorts of other content as well, and I really don't want it to be full of paragraph tags where they don't belong.

Solution:
You can use [wpv-autop] shortcode over that particular field in Content Template. And change Content Template >> Settings to >> Manual paragraphs.

This ways auto-paragraph will only work on the particular fields which are within this shortcode. For example:

[wpv-autop]
[types field='comments'][/types]
[/wpv-autop]

Relevant Documentation:
https://toolset.com/documentation/user-guides/views-shortcodes/#wpv-autop

This support ticket is created vor 5 Jahre, 4 Monate. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 12:00 – 17:00 12:00 – 17:00 12:00 – 17:00 12:00 – 17:00 12:00 – 17:00 -
- 18:00 – 21:00 18:00 – 21:00 18:00 – 21:00 18:00 – 21:00 18:00 – 21:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

This topic contains 2 Antworten, has 2 Stimmen.

Last updated by zoeS vor 5 Jahre, 4 Monate.

Assigned support staff: Noman.

Author
Artikel
#575743

Hello, I found in this thread (https://toolset.com/forums/topic/custom-fields-wysiwyg-field-not-auto-outputting-paragraph-tags/) which explains that to get wysiwyg fields to correctly output their paragraphs, it is necessary to use 'auto insert paragraphs' in the content template where they are displayed. The trouble is that my content template contains all sorts of other content as well, and I really don't want it to be full of paragraph tags where they don't belong. Is there any way around this? Thank you.

#575776

Noman
Supporter

Languages: Englisch (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Zoe,

Thank you for contacting Toolset support. You can use [wpv-autop] shortcode above that particular field in Content Template. And change Content Template >> Settings to >> Manual paragraphs.

Shortcode doc: https://toolset.com/documentation/user-guides/views-shortcodes/#wpv-autop

This ways auto-paragraph will only work on the particular fields which are within this shortcode. For example:

[wpv-autop]
[types field='comments'][/types]
[/wpv-autop]

I hope this resolves the issue, thank you

#575822

Brilliant, that's exactly what I needed, thank you!